Sonnox OXFORD-LIMIT-V2-HD

True Peak Limited Plugin for Mac and Win

OUR PART #: OXFORD-LIMIT-V2-HD Write the First Review.

The Oxford Limiter v2 plugin delivers maximum loudness, density, and presence while retaining the clarity and transient detail that conventional brick-wall limiting can't provide.
Learn More
Our Price: $399.31
List Price: $424.80
You save 6%!
Price-Matching Symbol. Low Price Guaranteed Download Arrow. Download Available

Related Products

The Oxford Limiter v2 plugin delivers maximum loudness, density, and presence while retaining the clarity and transient detail that conventional brick-wall limiting can't provide. With enhanced levels of processing and metering accuracy you can see and automatically correct otherwise invisible reconstruction overloads to conform to the accepted industry ITU-R BS.1770-4 standard.

Sonnox Oxford Limiter v2 Native Features:

  • Peak limiting with attack, release & variable soft-knee
  • Enhance section to increase perceived loudness
  • Recon meter shows actual rather than sampled signal
  • Auto Comp fixes recon errors without losing overall loudness: conforming to the industry's true peak measurement standard (ITU-RBS.1770-4)
  • Audition and apply TPDF dither for 24-bit and 16-bit output word lengths with four types of variable noise shaping
  • Four variable-strength noise shaping modes for use with highly dynamic program material
  • Full backwards compatibility with previous Plug-Inversions
  • Great library of factory presets to get you started

Sonnox Oxford Limiter v2 Native Specifications:

  • Compatibility: AAX Native, AAX DSP, Audio Units, VST
  • System Requirements
    • Pro Tools
      • Pro Tools 10.3.8 – 12 (AAX Native & AAX DSP)
      • Legacy support for OS X 10.4.11 – 10.6.8  & Windows XP: TDM/RTAS
      • iLok USB device with latest drivers
      • iLok2 required for AAX plug-ins
    • Audio Units
      • Audio Units-compatible application (Logic, Digital Performer etc.)
      • Mac OS X 10.7 – 10.11
      • Legacy 32-bit support for OS X 10.4.11 – 10.6.8
      • iLok USB device with latest drivers
      • iLok2 required for 64-bit plug-in
    • VST2
      • VST2-compatible application (Cubase, Nuendo, Sequoia etc.)
      • Mac OS X 10.7 – 10.11
      • Legacy 32-bit support for OS X 10.4.11 – 10.6.8 & Windows XP
      • iLok USB device with latest drivers
      • iLok2 required for 64-bit plug-in

To be the first to review this item, click here.

Add to Cart

We're sorry, only of this item available



Call a Sales Pro at 800-356-5844 for more information